Home PC Games Linux Windows Database Network Programming Server Mobile  
           
  Home \ Linux \ Eclipse 3.7.2 can not start solving under Ubuntu 14.04     - Terminal Linux command prints - echo (Linux)

- WebLogic administrator account and reset the password (Database)

- Ubuntu 14.04 installed NVIDIA graphics driver (Linux)

- Compression decompression command under Linux (Linux)

- Linux more efficient than select a model epoll (Linux)

- Use OpenSSL to generate a certificate detailed process (Linux)

- build Android environment on Ubuntu 12.04 (Server)

- Why is the ibdata1 file growing in MySQL? (Database)

- Manually generate AWR reports (Database)

- Java concurrent programming using the synchronized keyword ReentrantLock alternative primitive (Programming)

- GRUB2 boot Ubuntu Manual (Linux)

- Haproxy multi-domain certificate HTTPS (Server)

- Golang use Oracle database on Ubuntu 14.04 (Linux)

- Detailed driver compiled into the Linux kernel (Programming)

- Spring WebSocket Comments (Programming)

- Firewall Configuration Red Hat Enterprise Linux 4 (Linux)

- How to configure Proftpd server on Fedora 22 (Server)

- RHEL 6.5 KVM analytical use (Server)

- Redis data types Introduction (Database)

- CentOS 6.6 permanent method to modify the DNS address (Linux)

 
         
  Eclipse 3.7.2 can not start solving under Ubuntu 14.04
     
  Add Date : 2017-04-13      
         
         
         
  Solve Ubuntu 14.04 under Eclipse 3.7.2 does not start, reported Could not detect registered XULRunner to use or org.eclipse.swt.SWTError: XPCOM deal with such issues.

For the eclipse 3.7.2 in ubuntu 14.04 under not start, you need to

Org.eclipse.swt.browser.DefaultType = mozilla add a line within the config.ini file eclipse / configuration directory


#This Configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Thu Jan 15 11:18:24 CST 2015
org.eclipse.update.reconcile = false
eclipse.p2.profile = epp.package.jee
osgi.instance.area.default=@user.home/workspace
osgi.framework = file \: plugins / org.eclipse.osgi_3.7.2.v20120110-1415.jar
equinox.use.ds = true
eclipse.buildId = M20120208-0800
org.eclipse.swt.browser.DefaultType = mozilla
osgi.bundles = reference \: file \: org.eclipse.equinox.simpleconfigurator_1.0.200.v20110815-1438.jar@1 \: start
org.eclipse.equinox.simpleconfigurator.configUrl = file \: org.eclipse.equinox.simpleconfigurator / bundles.info
eclipse.product = org.eclipse.platform.ide
osgi.splashPath = platform \: / base / plugins / org.eclipse.platform
osgi.framework.extensions = reference \: file \: javax.transaction_1.1.1.v201105210645.jar
osgi.bundles.defaultStartLevel = 4
eclipse.p2.data.area=@config.dir /../ p2 /
eclipse.application = org.eclipse.ui.ide.workbench

So the error will not start that this is out of my google I can not explain why.

Can then start when you click on an embedded browser or webservie browser is not being given is not reflected in the current form outside the launch external browser

Also being given Could not detect registered XULRunner editing jsp to use

These are due to the eclipse of the embedded browser is not in force.

We should do this

A version for eclipse 3.7.2

Please go http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/2012/03/2012-03-02-03-32-11-mozilla-1.9.2/xulrunner-1.9.2.28pre .en-US.linux-x86_64.tar.bz2

Download the xulrunner-1.9.2.28pre.en-US.linux-x86_64.tar.bz2

Unzip to a problem such as the right to extract the I / opt / commonTools / xulrunner next there is a directory in / opt / commonTools / under.

tone @ ubuntu: / opt / commonTools $ ls -l
The total amount of 43176
drwxrwxr-x 13 tone tone 4096 12 Yue 20 12:35 Android-sdk-linux
drwxr-xr-x 6 root root 4096. 11 Yue 17 11:08 apache-ant-1.9.3
drwxr-xr-x 7 root root 4096. 11 Yue 17 10:30 apache-maven-3.2.2
drwxr-xr-x 9 root root 4096 10 Yue 9 2009 jdk1.5.0_22
-rwxr-xr-x 1 root root 44191305 1 Yue 13 16:16 jdk-1_5_0_22-linux-amd64.bin
drwxr-xr-x 11 root root 4096 3 2 2012 xulrunner Yue

The next boundary eclipse profile. eclipse.ini increase his -Dorg.eclipse.swt.browser.XULRunnerPath = / opt / commonTools / xulrunner

-startup
plugins / org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.library
plugins / org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Djava.library.path = / Usr / lib / x86_64-linux-gnu / jni
-Dorg.eclipse.swt.browser.XULRunnerPath = / Opt / commonTools / xulrunner
-Dosgi.requiredJavaVersion = 1.5
-XX: MaxPermSize = 256m
-Xms40m
-Xmx512m

After the above error your eclipse harmony

For Could not detect registered XULRunner to use or org.eclipse.swt.SWTError: XPCOM solution (installed XULRunner) for the latest myeclipse 2014 is still valid
     
         
         
         
  More:      
 
- Ora-00439: feature not enabled: managed standby (Database)
- To create a full command line Android Build System (Linux)
- Installation of network monitoring ntopng under CentOS 6.4 (Linux)
- Linux system security configuration Collection (Linux)
- Linux firewall Iptables study notes (Linux)
- JSON data normalization (normalize) (Programming)
- RHEL5 / 6 Installation Notes (Linux)
- Run two MySQL service on one server (Database)
- Linux, Firefox unloading and installation and upgrade (Linux)
- Ubuntu install Tonido private cloud services (Server)
- Java loop list to solve the problem of Joseph ring (Programming)
- Plasma 5.4 How to install on Kubuntu 15.04 (Linux)
- Use Visual Studio to compile and use WinGDB remote debugging embedded Linux programs (Programming)
- Linux file permissions chmod chown (Linux)
- Cobbler batch install Ubuntu / CentOS system (Linux)
- MySQL thread cache thread_cache_size parameter optimization (Database)
- Linux data recovery software efficiently practical application extundelete (Linux)
- Ubuntu install ruby (Linux)
- MySQL use the integer type (Database)
- Linux system installation and usage instructions Wetty (Linux)
     
           
     
  CopyRight 2002-2022 newfreesoft.com, All Rights Reserved.