Home IT Linux Windows Database Network Programming Server Mobile  
           
  Home \ Linux \ Ubuntu update bug fixes Daquan     - Install Python 3.3.4 under CentOS 6.4 (Linux)

- CentOS7 installed MySQL (Database)

- Under CentOS Linux automatic backup MySQL database daily (Database)

- Android code performance optimization tips (Programming)

- Syncthing: Private Security Synchronization tool to synchronize files between computers / folder (Linux)

- Computer security protection remove local and remote system log files (Linux)

- Struts2 : combobox label use (Programming)

- HDFS Distributed File System Resource Manager Developer summary (Server)

- OpenStack image production in the CentOS 6.2 (Linux)

- ORA-08102 errors (Database)

- Debian 7.7 Installation and Configuration (Linux)

- Linux --- manual release system cache (Linux)

- CentOS 6.x and CentOS7 install MPlayer (Linux)

- To install Scribus 1.4.4 under ubuntu (Linux)

- How to find the available network adapter on Ubuntu (Linux)

- Ubuntu Server security risk checks (Linux)

- Oracle archive log deletion (Database)

- Linux directory permissions to read and execute permissions difference (Linux)

- MySQL backup tool to back up mydumper (Database)

- GRUB how to load Linux kernel (Linux)

 
         
  Ubuntu update bug fixes Daquan
     
  Add Date : 2018-11-21      
         
       
         
  In Ubuntu update, who have not met a mistake? In Ubuntu and other Linux distributions based on Ubuntu, the update error is a common error, but also a frequent occurrence. These errors appear in a variety of repair is also very simple. In this article, we will see in Ubuntu update error types occur frequently and their fixes.

The combined list of issues

When you run the update command in a terminal, you might encounter this error "combined list of errors", as follows:

E: Encountered a section with no Package: header,

E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.comubuntudistspreciseuniversebinary-i386Packages,

E: The package lists or status file could not be parsed or opened '.

You can use the following command to fix the error:

sudo rm -r / var / lib / apt / lists / *
sudo apt-get clean && sudo apt-get update
 

Download warehouse information -1 on failure

In fact, there are two types of storage information failed to download error. If your error looks like:

W: Failed to fetch bzip2: /var/lib/apt/lists/partial/in.archive.ubuntu.comubuntudistsoneiricrestrictedbinary-i386Packages Hash Sum mismatch,

W: Failed to fetch bzip2: /var/lib/apt/lists/partial/in.archive.ubuntu.comubuntudistsoneiricmultiversebinary-i386Packages Hash Sum mismatch,

E: Some index files failed to download They have been ignored, or old ones used instead.

Well, you can use the following command to repair:

sudo rm -rf / var / lib / apt / lists / *
sudo apt-get update
 

Download warehouse information failed -2

Download warehouse information Another type of failure is caused due to the PPA outdated. Typically, when you run the update manager and see an error

You can run sudo apt-get update to see which PPA update fails, you can remove it from the source list. You can follow this guide to repair screenshot Download warehouse information failed error.

Downloadable files failed error

A similar error is to download the package files failed error like this

The errors are easy to fix, simply modify the software source-based server. Go to the "software and updates", where you can modify the download server is the primary server

Partial update error

In the terminal run the update will be part of the update error:

Not all updates can be installed

Run a partial upgrade, to install as many updates as possible

Run the following command in a terminal to fix the error:

sudo apt-get install -f
 

An error occurred while loading shared libraries

The error is more installation errors, not the update error. If you try to install a program from source, you may encounter this error:

error while loading shared libraries:

can not open shared object file: No such file or directory

The error by running the following command in a terminal to fix:

sudo / sbin / ldconfig -v
You can find here an error occurred while loading a shared library for more detailed information.

 

Could not get lock / var / cache / apt / archives / lock

In another program while using APT, the error occurs. Suppose you are Ubuntu Software Center to install a thing, and then you try to run in a terminal apt.

E: Could not get lock / var / cache / apt / archives / lock - open (11: Resource temporarily unavailable)

E: Unable to lock directory / var / cache / apt / archives /

Generally, as long as you have all the other programs use apt off, the problem will be good. However, if the problem persists, you can use the following command:

sudo rm / var / lib / apt / lists / lock
If the above command does not work, you can try this command:

sudo killall apt-get
For more information about the error, you can be found here.

 

GPG error: The following signatures could not be verified

When you add a PPA, it may cause the following error GPG error: The following signatures could not be verified, which usually occurs in the terminal running update:

W: GPG error: http://repo.mate-desktop.org saucy InRelease: The following signatures could not be verified because the public key is not available: NO_PUBKEY 68980A0EA10B4DE8

We have to do, is to get the public system, to obtain information from the key number. In the above information, the key number is 68980A0EA10B4DE8. This key can be used as follows:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 68980A0EA10B4DE8
After adding a key, run the update again no problem.

 

BADSIG error

Another signature-related update errors Ubuntu is BADSIG error, it looks like this:

W: A error occurred during the signature verification The repository is not updated and the previous index files will be used GPG error:.. Http://extras.ubuntu.com precise Release: The following signatures were invalid: BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key

W: GPG error: http://ppa.launchpad.net precise Release:

The following signatures were invalid: BADSIG 4C1CBC1B69B0E2F4 Launchpad PPA for Jonathan French W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/precise/Release

BADSIG To fix this error, use the following command in Terminal:

sudo apt-get clean
cd / var / lib / apt
sudo mv lists oldlist
sudo mkdir -p lists / partial
sudo apt-get clean
sudo apt-get update
This paper brings together you might encounter Ubuntu update error, I hope this will help you deal with these errors. Do you have encountered in Ubuntu update other wrong? Please tell me in the comments below, I will try to write a quick guide.
     
         
       
         
  More:      
 
- Help you enhance Python programming languages 27 (Programming)
- shell script: the number of characters in the text to print no more than 6 words (Programming)
- Linux command in the dialog whiptail (Linux)
- MongoDB learning Notes (2) basic connection example of -Nodejs and MongoDB (Database)
- By creating a personal technology blog Detailed GitHub (Linux)
- Grep how to find files based on file contents in UNIX (Linux)
- PHP call a Python program (Programming)
- Linux Network Programming - non-blocking program (Programming)
- Security Knowledge: How to hide a backdoor PHP file tips (Linux)
- Oracle 11g upgrade PSU detailed steps (Database)
- MySQL Basic tutorial: About varchar (N) (Database)
- Oracle 12c detailing the new features (Database)
- CentOS 6/7 Series Docker Installation (Linux)
- Java rewrite the hashcode method (Programming)
- Oracle SQL statement tracking (Database)
- sed command (Linux)
- Linux System Getting Started Learning: DeVeDe installed on Linux to create a video DVD (Linux)
- Ubuntu 15.10 under Python + Apache + CGI fully configured (Server)
- ASP.NET 5 tutorial series (Server)
- Introduces Linux kernel compilation system and compiler installation (Linux)
     
           
     
  CopyRight 2002-2016 newfreesoft.com, All Rights Reserved.